Synthesis AG - SyncML Discussion Forum

Synthesis AG - SyncML Discussion Forum (http://forum.synthesis.ch/index.php)
-   SyncML Clients for classic PDAs (WindowsMobile, PalmOS) (http://forum.synthesis.ch/forumdisplay.php?f=2)
-   -   Autosync isn't exactly automatic (http://forum.synthesis.ch/showthread.php?t=384)

lrsatlanta 2007-04-04 00:59

Autosync isn't exactly automatic
 
Hi there. I just purchased and downloaded the latest client for Palm, 3.0.0.2. I am using this on an unlocked GSM Treo 650 against Oracle Calendar Server version 9.0.4. Treo software revision is Treo650-1.20-ENA.

It works great as far as synchronizing calendar events goes, but the autosync doesn't seem to work unless the SyncML application is in the foreground. Perchance I am misunderstanding how this is supposed to work, but I went through the forums here, google and the manual that downloads with the software and it seems that it should not need to be in the foreground to autosync.

If I leave the SyncML app in the foreground, it autosyncs on schedule no problems. If I switch to another app, like say the phone, it never syncs until I switch back to the SyncML app. As soon as I switch to the SyncML app, the Autosync satus shows "inactive" but then changes to display the next scheduled sync time.

I'm at a bit of a loss now. Can someone give me a hint as to whether I am just misunderstanding or perchance this isn't functioning as it should?

Thanks.

-Lawrence

luz 2007-04-04 18:13

Re: Autosync isn't exactly automatic
 
Thanks for reporting the problem!

We just found there is indeed a bug which caused this. :(

However, the problem was only device when KeyGuard was active in the moment when AutoSync wanted to start a new sync, so that's why the problem was not detected earlier.

We just released an update to 3.0.1.2 which fixes this and a few other problems (especially compatibility with the T|X). You can get it using the "Check for Update" feature in the SyncML client software or manually at our website.

lrsatlanta 2007-04-05 18:45

Re: Autosync isn't exactly automatic
 
And it works! Hooray!

Thanks for your quick reply. This makes my day.

-Lawrence

lrsatlanta 2007-04-16 23:06

Re: Autosync isn't exactly automatic
 
OK, new problem, same basic concern.

Syncing is automatic now and works as advertised, mostly.

I now have a situation where it does not seem to be working correctly, however. This morning I picked up my palm and woke it up and noticed that it had not synchronized since last Friday. Given my settings as noted below, I would have expected it to be syncing since midnight. Once I woke it, it immediately synchronized and has been working as expected since.

My autosync settings are as follows:

Top line of settings: M-F 00:00-00:00 battery greater than 10% autosync mode "Timed"

Second line of settings: Sat-Sun 00:00-00:00 battery greater than 10% autosync mode "Off"

Other time/condition: Autosync mode "Off"

-Lawrence

abruenin 2007-06-08 15:22

Re: Autosync isn't exactly automatic
 
Quote:

Originally Posted by luz (Post 773)
We just released an update to 3.0.1.2 which fixes this and a few other problems (especially compatibility with the T|X). You can get it using the "Check for Update" feature in the SyncML client software or manually at our website.

as of your release notes, 3.x is not supported with Oracle Collaboration Suite. Did this change?

JohnDCCIU 2007-12-20 15:28

Re: Autosync isn't exactly automatic
 
Quote:

Originally Posted by lrsatlanta (Post 772)
Hi there. I just purchased and downloaded the latest client for Palm, 3.0.0.2. I am using this on an unlocked GSM Treo 650 against Oracle Calendar Server version 9.0.4. Treo software revision is Treo650-1.20-ENA.

It works great as far as synchronizing calendar events goes, but the autosync doesn't seem to work unless the SyncML application is in the foreground. Perchance I am misunderstanding how this is supposed to work, but I went through the forums here, google and the manual that downloads with the software and it seems that it should not need to be in the foreground to autosync.

If I leave the SyncML app in the foreground, it autosyncs on schedule no problems. If I switch to another app, like say the phone, it never syncs until I switch back to the SyncML app. As soon as I switch to the SyncML app, the Autosync satus shows "inactive" but then changes to display the next scheduled sync time.

I'm at a bit of a loss now. Can someone give me a hint as to whether I am just misunderstanding or perchance this isn't functioning as it should?

We've been having this same problem with our Treos (650 and 700p) since we started with Synthesis and the 3.0.2.x clients. We're up to 3.0.2.12 at this point and there's still no fix!

The problem is just as described above: it will Sync as intended for awhile, but then suddenly the app just doesn't activate any more. If the user then launches the app, without doing anything else at all, they can see by the last sync time that it hasn't synced for hours or days, even though it was supposed to, and the client immediately starts syncing. It then works as it should for another period of time (usually days), but eventually the same thing happens.

The big problem is that there's no way for the user to know that this is happening...their stuff simply isn't synced....until they visit the app. That's fine for technical types that like to play with their phones, but for the VIPs that want it to just work, this isn't cutting it!

When will this be fixed?

JohnDCCIU 2008-01-11 00:30

Re: Autosync isn't exactly automatic
 
Bump!

What's going on with this bug?

taroliw 2008-01-11 12:38

Re: Autosync isn't exactly automatic
 
Quote:

Originally Posted by JohnDCCIU (Post 1296)
We've been having this same problem with our Treos (650 and 700p) since we started with Synthesis and the 3.0.2.x clients. We're up to 3.0.2.12 at this point and there's still no fix!

I think it's a general issue with the PalmOS client, as I have the same behavior on my 680 as well.

luz 2008-01-15 17:29

Re: Autosync isn't exactly automatic
 
Quote:

Originally Posted by taroliw (Post 1332)
I think it's a general issue with the PalmOS client, as I have the same behavior on my 680 as well.

We're still trying to reproduce this here, with no success so far (that's why you haven't heard more from us about that bug or a fix). We need to be able to catch this "live" at least once to debug it.

One piece of information that could help us: In the thread it is said the autosync works "for a while". How long approximately is such a while? Hours? Days? Weeks? And what is the frequency set for autosync?

taroliw 2008-01-15 20:16

Re: Autosync isn't exactly automatic
 
Quote:

Originally Posted by luz (Post 1334)
We're still trying to reproduce this here, with no success so far (that's why you haven't heard more from us about that bug or a fix). We need to be able to catch this "live" at least once to debug it.

One piece of information that could help us: In the thread it is said the autosync works "for a while". How long approximately is such a while? Hours? Days? Weeks? And what is the frequency set for autosync?

Personally, I've never seen it work longer than a day. I've gotten into the habit of manually bouncing into SyncML at least once or twice a day to be sure it's syncing. And, more often than not, it hasn't synced and wakes up to do it as soon as I open the application.


All times are GMT +2. The time now is 12:58.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.