View Single Post
  #5  
Old 2011-11-07, 14:42
socks socks is offline
Junior Member
 
Join Date: 2010-06
Posts: 4
Default Re: Problem nach Update von 2.0.17 auf 2.1.1

So, ich habe jetzt den Synthesis Client deinstalliert und die Version 2.1.10 neu instaliiert.
Meine Einstellungen sind erhalten geblieben.
Nach dem ersten Sync im "Reload Device" Modus ist der selbe Effekt wie vorher aufgetreten. Innerhalb kurzer Zeit verschwinden meine Kalendereinträge bis auf einige wenige.
Ich habe mir dann die Einstellungen nochmal genau angeschaut und festgestellt, dass bei den Events die Option "Items with non-matching categories will be synced to:" auf "Deutsche Feiertage" steht. Hier wurde also meine Einstellung von Version 2.0.17 nicht richtig übernommen.
Bislang stand dort "cal1", also der vom Synthesis Client generierte Kalender.
Jetzt ist mir auch klar, warum die Einträge verschwunden sind. Der Deutsche Feiertage Kalender von Google ist read-only. Bei einem Sync mit Google sind die lokalen Einträge deshalb gelöscht worden.
Nach einigem Rumprobieren, indem ich die anderen Kalender in den Einstellungen erst deaktiviert und dann wieder aktiviert habe, steht jetzt wieder "cal1" drin.
Wenn ich jetzt einen "Reload Device" Sync mache, werden ALLE meine Kalendereinträge vom Server in cal1 geschrieben unabhänigig von ihrer Kathegorie. Das ist aber nicht richtig so!
Mein MDaemon SyncML Server hat zu den Einträgen auch die Kathegorie gespeichert. Das sieht im entsprechenden File dann so aus:

Quote:
<Event ID="92" Sequence="0" Priority="1" BusyStatus="2" AllDay="1">
<Modified>2011-06-29 17:54:16</Modified>
<iCalUid>4f6b644a474d463d955a03ff50028720</iCalUid>
<Start>2011-10-31 00:00</Start>
<End>2011-10-31 23:59</End>
<Subject><![CDATA[Reformationstag]]></Subject>
<Categories><![CDATA[cal=Deutsche Feiertage]]></Categories>
<Creator><![CDATA[my@email.net]]></Creator>
<Planner><![CDATA[my@email.net]]></Planner>
<Attendee Type="0" Invite="1" Sent="1" Status="0">
<Email><![CDATA["Deutsche Feiertage" <de.german#holiday@group.v.calendar.google.com>]]></Email>
</Attendee>
</Event>
oder so:

Quote:
<Event ID="97" Sequence="0" Priority="1" BusyStatus="2" AllDay="1">
<Modified>2011-06-29 17:59:05</Modified>
<iCalUid>1c231136c2c044f4aba46631e8405aec</iCalUid>
<Start>2012-01-02 00:00</Start>
<End>2012-01-02 23:59</End>
<Subject><![CDATA[Kalenderwoche 1 2012]]></Subject>
<Categories><![CDATA[cal=Wochennummern]]></Categories>
<Creator><![CDATA[my@email.net]]></Creator>
<Planner><![CDATA[my@email.net]]></Planner>
<Attendee Type="0" Invite="1" Sent="1" Status="0">
<Email><![CDATA["Week Numbers" <e_2_de#weeknum@group.v.calendar.google.com>]]></Email>
</Attendee>
</Event>
oder so:

Quote:
<Event ID="168" Sequence="2" Priority="1" BusyStatus="0">
<Modified>2011-07-04 14:21:02</Modified>
<iCalUid>cd023ca1dd034e4ab982a1b093150f12</iCalUid>
<Start>2011-07-13 22:00</Start>
<End>2011-07-13 23:58</End>
<Subject><![CDATA[Electro Art & Maschinen Pop]]></Subject>
<Categories><![CDATA[cal=cal1]]></Categories>
<Creator><![CDATA[my@email.net]]></Creator>
<Planner><![CDATA[my@email.net]]></Planner>
<Location><![CDATA[Die Bank München]]></Location>
</Event>
Einträge, die ich am Server direkt gemacht habe, enthalten keine Kathegorie und sollten deshalb unter cal1 einsortiert werden:

Quote:
<Event ID="156" Sequence="2" Priority="1" BusyStatus="0" AllDay="1">
<Modified>2011-07-04 14:26:35</Modified>
<iCalUid>72be4ca576314f29875c16b38aa96183</iCalUid>
<Start>2011-07-16 00:00</Start>
<End>2011-07-17 23:59</End>
<Subject><![CDATA[Amphi Festival]]></Subject>
<Creator><![CDATA[my@email.net]]></Creator>
<Planner><![CDATA[my@email.net]]></Planner>
<Location><![CDATA[Tanzbrunnen Köln]]></Location>
</Event>
Wieso funktioniert das richtige Einsortieren nach Kathegorien ab Version 2.1.1 nicht mehr?
Mir ist klar, dass ich die Wochennummern und Deutschen Feiertage nicht unbedingt zum MDaemon Server syncen müsste, es ist aber ganz praktisch die dort auch zu haben.
Bin jetzt wieder zurück zu 2.0.17.

Gruß,

Axel
Reply With Quote