View Single Post
  #1  
Old 2014-02-02, 14:08
Al_ Al_ is offline
Junior Member
 
Join Date: 2013-04
Posts: 4
Default Occasionally all contacts are lost after sync

Hi

Occasionally, after sync'ing contacts with SyncML between a phone and the server, most/all contacts are deleted on both sides (luckily, the contacts are still available on other devices, so the server can be reloaded; a subsequent SyncML reload of the initially affected client restores the contacts).

Looking at the log file on the server side (in part attached), I have to conclude that SyncML did not send any contact items but claims that all contacts on the client had been previously deleted. This is not true; there were appr. the same number of entries on the client device prior to the sync as on the server.

Prior to repairing the server database by updating from another device, I saved the relevant folders (~/.local/share/evolution and ~/.config/syncevolution), in the hope that this will help to locate the issue. I also have the log files of the server.

Setup:
- server: syncevo-http-server, running on Ubuntu precise (12.04.2 LTS)
- most recently affected client: Samsung GT-S5360 (Android 2.3.6), running SyncML STD 2.8.6, SyncML engine Version V3.4.0.68
- two Ubuntu machines running evolution and syncevolution (neither ever had an issue, so far)
- one android (version 3.2) device with SyncML lite
- one android (version 4.) device with SyncML STD
- one iOS device (version 6.1.3) with SyncML lite.

How can I fix this issue?

Best

Al_
Attached Files
File Type: txt syncevo-log.txt (3.5 KB, 2 views)
Reply With Quote