Synthesis AG - SyncML Discussion Forum  

Go Back   Synthesis AG - SyncML Discussion Forum > Synthesis SyncML Products (english) > SyncML Clients for classic PDAs (WindowsMobile, PalmOS)

Reply
 
Thread Tools Display Modes
  #1  
Old 2006-10-01, 18:51
Dorowan Dorowan is offline
Junior Member
 
Join Date: 2006-10
Posts: 8
Default Palm Clients will not connect through Proxy

Hello!
I have tested the stable version and the most recent beta (2.9.9.3) of the palm client. Both versions will not connect through the proxy my mobile provider wants me to use. I tried to connect via https. If I turn the proxy of I can reach the Sync-Server (tried eGroupware and c't-Synthesis). If I use the proxy (http proxy on port 8080) I only get an connection error after some changes between "sending..." and "waiting...".

Might it be problem that it is only a web/wap-proxy? I thought SyncML is http only.

Greets,
Carsten
Reply With Quote
  #2  
Old 2006-10-02, 14:50
luz's Avatar
luz luz is offline
plan44.ch
 
Join Date: 2006-06
Posts: 348
Default Re: Palm Clients will not connect through Proxy

This is most probably because the proxy is intended for web browsing, and not SyncML (which is HTTP, but not HTML inside, but binary WBXML). In fact, even "smart" proxies of mobile carriers that seem to work on the first sight can cause troubles, because they usually try to "optimize" data for web browsing but sometimes ruin SyncML messages doing that.

A straight HTTP proxy (such as squid) however works ok for SyncML.

One thing you might try (if your server supports it): Use https instead of http. With https, the proxy is forced to forward data 100% unchanged, so this often helps.
__________________
Lukas Zeller, plan44.ch
Reply With Quote
  #3  
Old 2006-10-02, 17:19
Dorowan Dorowan is offline
Junior Member
 
Join Date: 2006-10
Posts: 8
Default Re: Palm Clients will not connect through Proxy

Quote:
One thing you might try (if your server supports it): Use https instead of http. With https, the proxy is forced to forward data 100% unchanged, so this often helps.
Yes, I read this advice already somewhere on the synthesis page or in this forum. I do use https - with self signed certificate. If I disable the proxy this works. The client notifies me that the certificate is not well signed and then it does sync. If I enable the proxy there is no contact to the server - not even the message about the untrusted certificate. The same proxy settings work with https for websurfing - in fact I simply copied them in the format: <ip>:<port>
Might it be a problem that I only entered a http-proxy?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +2. The time now is 11:00.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.