Synthesis AG - SyncML Discussion Forum  

Go Back   Synthesis AG - SyncML Discussion Forum > Synthesis SyncML Products (english) > SyncML Servers (Linux, Windows, MacOS X)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 2008-05-07, 06:37
reedhe reedhe is offline
Junior Member
 
Join Date: 2007-11
Posts: 3
Default Problem in syncing against Deom server3.0.3.4 over OBEX/TCP

Hi!
These days I've been syncing my SyncML Client against Synthesis Demo Server3.0.3.4 in order to test the OBEX implementation and to see whether it works OK with SyncML Client.
After a successful (OBEX)Connect and Put command, I send a Get command to retrieve the first message generated by the Demo Server. The package is too long to fit in one OBEX message, they're separated in multi-package. According to the OBEX spec, the body header of the last chunk of the multi-package should be 0x49 to indicate that this is the final chunk, but what I get from the Demo server is 0x48 which indicate a chunk of the package but not the final. I wondered if this is a problem of the implementation of OBEX of the Demo Server3.0.3.4?

expect your response
Reply With Quote
 

Tags
obex

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +2. The time now is 10:09.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.