Synthesis AG - SyncML Discussion Forum  

Go Back   Synthesis AG - SyncML Discussion Forum > Synthesis SyncML Products (english) > Todo+Cal+Sync and SyncML PRO/LITE for iOS (iPhone, iPad, iPod touch)

Reply
 
Thread Tools Display Modes
  #1  
Old 2009-06-18, 12:01
RalfW RalfW is offline
Junior Member
 
Join Date: 2006-10
Location: Germany, Northrhine-Westphalia
Posts: 6
Question iPhone SyncML - wich protocol versions supported?

Hi All,

just trying to find out wich SyncML version is supported by the iPhone SyncML client from AppStore.

I checked the documents and so far it is working with v1.2 and is downwards compatible.

Is it possible to select and store SyncML v1.1 explicitly like in your other SyncML Clients?
This is important as the actually used SyncML server supports v1.1 only and runs synchronisation of calendar, contacts and ToDo's against GroupWise 7.
(This works well with your clients fpr PalmOS and WinMobilePDAs.)

Thanks and best regards
Ralf
Reply With Quote
  #2  
Old 2009-06-22, 10:05
RalfW RalfW is offline
Junior Member
 
Join Date: 2006-10
Location: Germany, Northrhine-Westphalia
Posts: 6
Default Re: iPhone SyncML - wich protocol versions supported?

Hello Everybody,

as my first question was not answer by now, I like to be a bit more precise:

Does SyncML-Client for iPhone support protocol version 1.1 ??

Going through thedocumentation, there are plenty words spend in setting the correct database path and so on,but I did not find explanation nor options given for the "protocol settings" in the application.

This could mean either:
a) there is a button to open menu, but did not offer a choice rather than 1.2
b) there is a button but to open a menu planned for further releases. This in fact will limit the actual version to protocol v1.2 as well or
c) there is menu behind wich allows user to change protocol to v1.1 or 1.0?

Due to the fact that it is not a good idea to spend money for a 24 month contract and buy in the iPhone for testing, I like to get this simple question answered beforehand.

Every comment or even actual statement from experienced users is very welcome.

Thanks and best regards

Ralf
Reply With Quote
  #3  
Old 2009-06-30, 10:32
RalfW RalfW is offline
Junior Member
 
Join Date: 2006-10
Location: Germany, Northrhine-Westphalia
Posts: 6
Smile Re: iPhone SyncML - wich protocol versions supported?

Hello guys,

just got from Sythesis a kind response I like to share with all of you about the SyncML protocol handling.

The Synthesis SyncML Client for iPhone automatically detects the version during communication initialising. If the SyncML-Server does not run in protocol v1.2, the client will "switch" downwards compatible to v1.1 or v1.0.

If there are certain cases where the server seems to run v1.2 but does not have it implemented completelly, users may set the protocol of the CLIENT manually to e.g. v1.1.

We will give it a try ...

Thanks to the Synthesis Team.

Regards
Ralf
Reply With Quote
Reply

Tags
iphone, protocoll, support, syncml, v1.1

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +2. The time now is 23:33.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.